'Unresolved dependencies' と警告される場合

Rollup はデフォルトでは npm などから追加したライブラリなどを使うことを想定していないようです。これを解決するにはrollup-plugin-node-resolveプラグインを使います。「依存がある時に追加するプラグイン」、と覚えるといいと思います。

設定例

// 依存に追加
// ```
// yarn add -D rollup-plugin-node-resolve
// ```
//
import nodeResolve from 'rollup-plugin-node-resolve';

export default {
  input: '...',
  plugins: [
    nodeResolve(),
  ]
}