エラー

Error logging in to v2 endpoint, trying next endpoint: ...

恐らくDockerデーモンが起動していない。

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock.

Linuxカーネルが古い。(2019-08-21時点で)最新のバージョンでは3.10+を要求しているので、バージョンがそれ以下の可能性があります。

uname -r                                                                  
# 2.6.32-042stab120.6

また古い場合はdockerdコマンドの最後で以下のようなエラーメッセージを確認できるはずです。

dockerd
# ...
# FATA[2019-08-21T12:34:44.647055425+09:00] Your Linux kernel version 2.6.32-042stab120.6 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer.

No space left on device

残っている volume をすべて削除したら治りました。

sh -c 'docker volume rm -f $(docker volume ls -q)'