CLI をインストール

Rust (Cargo)が使えるなら以下を叩くだけでインストールできます。

cargo install diesel_cli
diesel --version
# diesel 1.4.0

エラー関連

note: /usr/bin/ld: cannot find -lmysqlclient collect2: error: ld returned 1 exit status

ubuntu-18.04 で起こりました。

以下で治りました。

sudo apt install gcc default-mysql-client

またはmysql機能を使わない、例えばpostgresしか使わないのであれば以下でインストールでも回避できます。

cargo install diesel_cli --no-default-features --features postgres

failed to compile diesel_cli v1.4.0, intermediate artifacts can be found

macOS で起こりました。

以下で治りました。

cargo +stable install diesel_cli